Behavior Details not showing in IDE

####**1. Behavior Tree Details not showing up in IDE
When I click on a behavior item only the decorator arguments are showing up in the right hand display. This wasn’t always the case. I’ve been developing just fine. It seemed to start once I did a npm install jibo --save and the jibo version went from 3.0.0 to 3.0.7. Could be a red herring, but its the only thing I can think of that I did. After the issue showed up, I installed and uninstalled the SDK several times, taking down the atom editor after uninstall. After a few tries, I re-installed the atom editor itself. Still didn’t work. Crazy thing is that the simulator still works. Its just the behavior editor doesn’t show all parts of the behavior. I’ve looked at the behavior json file and the code is there - it just doesn’t display in the IDE. Maybe this is just a setting somewhere that I accidentially hit, but I can’t find it if it is.

Shot 1 - Decorator only - No code. Its not hidden either in a shrunken split window.

Shot 2 - Hello world. Works in sim, but no code shows in editor.

####2. Your Current Setup with SDK

Providing details about your system/SDK setup can save time by pre-answering common questions the community may ask.

  • Operating System: Windows 10
  • Amount of RAM: 16 GB
  • Node Version: 5.7.0
  • Atom version: 1.9.9
  • Does it say {$project} in your Run Directory area? (to right of simulator play button): No. I put in direct path to my projects, so I can load multiple in tree. Even with the problem, I can still run successfully in the simulator, so its just an IDE/SDK display issue for behaviors.

If you are using Windows

  • Command line tool (Git Shell or Git Bash): 2.6.4
  • Visual Studio Version: 2015 Community

Hey @mccune21,

I’m sorry you are seeing this problem. Other people have seen this behavior and sometimes this can do with a simple setting in Atom even after reinstalling the SDK. Can you try following these steps to Reset the Behavior Editor view setting in Atom?

Let me know if this helps or if this behavior continues so we can dig into this deeper for you.

Awesome! That was easy. Thank you very much.