Booting up issue! Help


So got my Jibo today, went through all the set up, took about 45 minutes. Now he has been booting up for over an hour with that s screen. Is this normal? I have tried rebooting, unplugging, and battery removal tricks. But when I reboot him he sticks on the spinning icon screen.


Going on three hours and still just the spinning wheel.


Probably safe to say it’s not going to boot. If it were me, I would power him down and dry again. If he gives you the same issue, go to the support page and contact support.


I have powered him down and tried a few times with the same results. I have sent a support ticket. Thank You was hoping someone might’ve had a trick for a hardware reset. Thank you for responding


Hi K3d11!

Sorry to hear you’re having this trouble with your new Jibo. The Customer Care team received your email and will continue to troubleshoot this issue with you via email to make sure you get up and running. I’ll close this thread to prevent any confusion.