Enable Ryzen virtualization for Win10 Home


#1

Recently I am facing a crazy problem,I have tried the recommended solutions that I could find. I plan on digging deeper, but I was hoping to get some suggestions on where to focus my efforts.

Is there an easy way to identify services that might be using hardware virtualization and causing a conflict? Going through every service one by one will be very painful.

I tried updating my chipset drivers today with no luck. There is a new BIOS for my motherboard, but the release notes imply that it was just to add support for thread ripper.

Software with running services:

  • Oracle

  • SQL Server Express 14/16

  • Team Foundation Server

  • Visual Studios 2010-17

  • MS Defender

Normally run Folding @Home in the background, but I turned that off while testing.

Disabled Incredibuild.

I’m running Windows 10 Home 64 bit on a Ryzen 7. I’m trying to get Virtualbox to run a 64 bit VM, but only 32-bit options are available. The Acceleration tab in the settings is disabled.

Based on searching around I’ve checked:

  • I have enabled virtualization in the BIOS
  • I did a hard power cycle, not just a reboot
  • In task manager, my CPU shows as “Virtualization: Disabled”, and “Hyper-V support: Yes”
  • Hyper-V doesn’t come with Windows 10 Home, so it’s already disabled (Although, I ran “dism.exe /Online /Disable-Feature: Microsoft-Hyper-V”, and got a “Feature Unknown” error as expected)
  • I have seen that Avast is a common culprit, but I’m not running that.

I know Virtualbox can run a 64bit VM on Windows 10 Home because I can do that on my laptop (although that is an i7, not a Ryzen). Most of the software I’m running is the same between the two systems, but not identical. I can’t think of any obvious differences between them, though.

Update

  • I uninstalled my Android SDK since I won’t need it for a while.
  • I disabled all of the apps in the Task Manager Startup tab.
  • I went into the System Configuration Boot menu and rebooted in Diagnostic startup mode
  • I used the Sysinternals Process Explorer (with the Virtualization column turned on) to compare the running processes between Safe Mode and Diagnostic Mode. Nothing was listed as virtualized in either case, and the Diagnostic mode actually had fewer running processes than Safe Mode.

I still only see 64bit VMs listed when running in Safe Mode.

Thanks & Regards
Camillelola
(Oracle Developer)


#2

Hai,
Are you sure AMD-V is enabled? Which Ryzen 7 CPU do you have exactly? There are several. I would also try booting into Safe Mode, to see if only starting the bare minimum, still shows virtualization has been disabled.
Regards,
riya.
Oracle Developer