Error selecting an eye keyframe in the animation editor


#1

####1. Describe Your Issue

when i delete to default eye layer and i insert a new one i get this error selecting the first keyframe. I didnt use the default eye layer because making any modification on it don’t apear in the simulation.

thanks in adavance for some feedback

error report:

[Enter steps to reproduce below:]

Atom Version: 1.11.2
Electron Version: 0.37.8
System: MARCO-PC
Thrown From: jibo-sdk package, v1.7.1

Stack Trace

Uncaught TypeError: Cannot read property ‘x’ of undefined

At C:\Users\marco\.atom\packages\jibo-sdk\node_modules\jibo-keyframes\lib\jibo-keyframes.js:9

TypeError: Cannot read property 'x' of undefined
    at Function.i.value (C:\Users\marco\.atom\packages\jibo-sdk\node_modules\jibo-keyframes\lib\jibo-keyframes.js:9:20842)
    at Function.l.value (C:\Users\marco\.atom\packages\jibo-sdk\node_modules\jibo-keyframes\lib\jibo-keyframes.js:9:23983)
    at Function.u.value (C:\Users\marco\.atom\packages\jibo-sdk\node_modules\jibo-keyframes\lib\jibo-keyframes.js:9:5461)
    at t.s.value (C:\Users\marco\.atom\packages\jibo-sdk\lib\jibo-sdk.js:10:11223)
    at exports.default.o.default.createClass.getDOFs (C:\Users\marco\.atom\packages\jibo-sdk\lib\jibo-sdk.js:12:23235)
    at exports.default.o.default.createClass.onDataChanged (C:\Users\marco\.atom\packages\jibo-sdk\lib\jibo-sdk.js:12:24645)
    at emitNone (events.js:85:20)
    at t.emit (events.js:179:7)
    at e.n.value (C:\Users\marco\.atom\packages\jibo-sdk\lib\jibo-sdk.js:10:25617)
    at o.default.createClass.paste (C:\Users\marco\.atom\packages\jibo-sdk\lib\jibo-sdk.js:10:31136)
    at CommandRegistry.module.exports.CommandRegistry.handleCommandEvent (C:\Users\marco\AppData\Local\atom\app-1.11.2\resources\app.asar\src\command-registry.js:260:29)
    at C:\Users\marco\AppData\Local\atom\app-1.11.2\resources\app.asar\src\command-registry.js:3:61
    at KeymapManager.module.exports.KeymapManager.dispatchCommandEvent (C:\Users\marco\AppData\Local\atom\app-1.11.2\resources\app.asar\node_modules\atom-keymap\lib\keymap-manager.js:580:16)
    at KeymapManager.module.exports.KeymapManager.handleKeyboardEvent (C:\Users\marco\AppData\Local\atom\app-1.11.2\resources\app.asar\node_modules\atom-keymap\lib\keymap-manager.js:388:22)
    at WindowEventHandler.module.exports.WindowEventHandler.handleDocumentKeyEvent (C:\Users\marco\AppData\Local\atom\app-1.11.2\resources\app.asar\src\window-event-handler.js:114:36)
    at HTMLDocument.<anonymous> (C:\Users\marco\AppData\Local\atom\app-1.11.2\resources\app.asar\src\window-event-handler.js:3:61)

Commands

     -5:27.7.0 jibo-sdk:new-animation-file (span.name.icon.icon-file-directory)
  3x -4:58.3.0 jibo-sdk:confirm (input.native-key-bindings)
     -4:50.7.0 jibo-sdk:upsert-all (div.)
  2x -4:07.3.0 jibo-sdk:upsert-keyframe (div.animation-preview)
     -3:12.2.0 core:copy (div.)
     -3:10.9.0 core:paste (div.)
     -3:02.8.0 core:copy (div.)
     -2:57.2.0 core:paste (div.)
     -1:47.2.0 jibo-sdk:upsert-keyframe (div.)
  2x -1:45.7.0 jibo-sdk:start-playing (div.)
     -1:28.9.0 jibo-sdk:delete (div.)
     -1:18.1.0 jibo-sdk:upsert-keyframe (div.)
     -1:08.1.0 jibo-sdk:start-playing (div.)
     -0:08.2.0 core:copy (div.)
     -0:06.3.0 core:paste (div.)

Config

{
  "core": {
    "telemetryConsent": "no"
  },
  "jibo-sdk": {
    "AnimationEditor": "[{\"size\":1152.5416936005172,\"children\":[{\"size\":516.75,\"children\":[{\"size\":693.612074103673,\"children\":[]},{\"size\":450.92961949684434,\"children\":[]}]},{\"size\":362.75,\"children\":[]}]},{\"size\":335.4583063994828,\"children\":[]}]",
    "BehaviorEditor": "[{\"size\":786.4999999999999,\"children\":[{\"size\":-24,\"children\":[]},{\"size\":-24,\"children\":[]}]},{\"size\":760.4999999999999,\"children\":[{\"size\":599.3320556501988,\"children\":[]},{\"size\":280.16794434980125,\"children\":[]}]}]",
    "RunConfiguration": {}
  }
}

Installed Packages

# User
atom-beautify, v0.29.13 (inactive)
atom-html-preview, v0.1.22 (active)
color-picker, v2.2.2 (active)
jibo-sdk, v1.7.1 (active)
atom-dark-syntax, v0.27.0 (inactive)
atom-dark-ui, v0.52.0 (inactive)
atom-light-syntax, v0.28.0 (inactive)
atom-light-ui, v0.44.0 (inactive)
base16-tomorrow-dark-theme, v1.2.0 (inactive)
base16-tomorrow-light-theme, v1.2.0 (inactive)
one-dark-ui, v1.6.0 (active)
one-light-ui, v1.6.0 (inactive)
one-dark-syntax, v1.3.0 (active)
one-light-syntax, v1.3.0 (inactive)
solarized-dark-syntax, v1.0.2 (inactive)
solarized-light-syntax, v1.0.2 (inactive)
about, v1.7.0 (active)
archive-view, v0.61.1 (active)
autocomplete-atom-api, v0.10.0 (active)
autocomplete-css, v0.11.2 (active)
autocomplete-html, v0.7.2 (active)
autocomplete-plus, v2.31.1 (active)
autocomplete-snippets, v1.11.0 (active)
autoflow, v0.27.0 (inactive)
autosave, v0.23.1 (active)
background-tips, v0.26.1 (active)
bookmarks, v0.42.0 (active)
bracket-matcher, v0.82.1 (active)
command-palette, v0.38.0 (inactive)
deprecation-cop, v0.54.1 (active)
dev-live-reload, v0.47.0 (active)
encoding-selector, v0.22.0 (active)
exception-reporting, v0.40.0 (active)
find-and-replace, v0.201.1 (inactive)
fuzzy-finder, v1.4.0 (active)
git-diff, v1.1.0 (active)
go-to-line, v0.31.0 (inactive)
grammar-selector, v0.48.2 (active)
image-view, v0.59.0 (active)
incompatible-packages, v0.26.1 (active)
keybinding-resolver, v0.35.0 (active)
line-ending-selector, v0.5.0 (active)
link, v0.31.1 (inactive)
markdown-preview, v0.158.0 (active)
metrics, v1.0.0 (active)
notifications, v0.65.1 (active)
open-on-github, v1.2.0 (inactive)
package-generator, v1.0.0 (inactive)
settings-view, v0.242.2-hotfix1 (active)
snippets, v1.0.2 (active)
spell-check, v0.68.2 (active)
status-bar, v1.4.1 (active)
styleguide, v0.47.0 (active)
symbols-view, v0.113.1 (inactive)
tabs, v0.101.0 (active)
timecop, v0.33.2 (active)
tree-view, v0.209.3 (active)
update-package-dependencies, v0.10.0 (active)
welcome, v0.35.1 (active)
whitespace, v0.33.0 (active)
wrap-guide, v0.38.2 (active)
language-c, v0.52.1 (active)
language-clojure, v0.21.0 (active)
language-coffee-script, v0.47.2 (active)
language-csharp, v0.12.1 (active)
language-css, v0.37.1 (active)
language-gfm, v0.88.0 (active)
language-git, v0.15.0 (active)
language-go, v0.42.1 (active)
language-html, v0.45.1 (active)
language-hyperlink, v0.16.0 (active)
language-java, v0.23.0 (active)
language-javascript, v0.119.0 (active)
language-json, v0.18.2 (active)
language-less, v0.29.5 (active)
language-make, v0.22.2 (active)
language-mustache, v0.13.0 (active)
language-objective-c, v0.15.1 (active)
language-perl, v0.35.0 (active)
language-php, v0.37.2 (active)
language-property-list, v0.8.0 (active)
language-python, v0.45.0 (active)
language-ruby, v0.69.0 (active)
language-ruby-on-rails, v0.25.0 (active)
language-sass, v0.56.0 (active)
language-shellscript, v0.22.4 (active)
language-source, v0.9.0 (active)
language-sql, v0.23.0 (active)
language-text, v0.7.1 (active)
language-todo, v0.28.0 (active)
language-toml, v0.18.0 (active)
language-xml, v0.34.9 (active)
language-yaml, v0.26.0 (active)

# Dev
No dev packages

####2. Your Current Setup with SDK

Providing details about your system/SDK setup can save time by pre-answering common questions the community may ask.

  • Operating System:win10
  • Amount of RAM: 8GB
  • Node Version:4.4.7
  • Atom version:1.11.2
  • Does it say {$project} in your Run Directory area? (to right of simulator play button): yes

If you are using Windows

  • Command line tool (Git Shell or Git Bash): git bash

  • Visual Studio Version:

    If you are using Mac

  • Do you have Xcode command line tools installed? (xcode-select --install in terminal): no


#2

Hey @covolmar,

It seems like there is an issue with your jibo-keyframes dependency in your Jibo-SDK. Can you confirm what version of iTunes/Bonjour and Visual Studio you have? There are a few things that may be causing this:

  1. ) Make sure your skill’s package.json file has the following:
    "dependencies": { "behaviorify": "^1.0.0", "jibo": "^3.0.0" },

  2. ) In your command line tool, cd into your skill directory. rm -rf node_modules; npm i to remove and reinstall your skill’s node_modules.

  3. ) Pixi.js may not be installed in your cd C:/Users/<username> and C:/Users/<username>/.atom/packages/jibo-sdk/node_modules directories. To install, run this command in your command line tool:
    cd C:/Users/<username>; npm install pixi.js; cd C:/Users/<username>/.atom/packages/jibo-sdk; npm install pixi.js

  4. ) An issue with the Jibo-SDK installation. Please follow these steps to [disable]https://developers.jibo.com/sdk/docs/getting-started/#disable-the-jibo-atom-package) and uninstall the Jibo-SDK and then follow these steps to reinstall the Jibo-SDK again.

  5. ) Visual Studio Community 2015 may not be installed or a different version may be installed. Can you confirm what version of Microsoft Visual Studio you have installed by going to Control Panel > Programs > Programs and Features ? If this specific version of Visual Studio is not installed, please follow these steps to disable and uninstall the Jibo-SDK before installing Visual Studio Community 2015. Then install Pixi.js by running this command in your command line tool:
    cd C:/Users/<username>; npm install pixi.js ,
    follow these steps to reinstall the Jibo-SDK again, and then run this command in your command line tool:
    `cd C:/Users//.atom/packages/jibo-sdk; npm install pixi.js``.

  6. ) Check to make sure you followed all the Getting Started Guide steps in order. Some of these steps have changed and the order the dependencies are installed can impact how the SDK runs.

Let me know if this helps. If not, can you can share your version of Visual Studio, post code from <skillDir>/package.json and C:/Users/<username>/.atom/packages/jibo-sdk/node_modules/jibo-keyframes/package.json as well as a screenshot of your C:/Users/<username>/.atom/packages/jibo-sdk/node_modules directory, that will help me troubleshoot this further. :slight_smile:


#3

Hey @joe.t

thanks for your quick answer and solutions!
I’ve followed all your instructions and checked the configs but the error still appeard.

So I’ve completely reinstalled everthing(visual studio and sdk). and checked all your configs in the post. then i deleted also the old animations and created new ones. at the moment it seems to work fine. i didn’t received the error again.

I’ve installed visual studio enterprise edition verison 14.0.254331.01 instead of the community edition. can you confirm that it isnt a problem?

If the errors returns again I will let you know and send you all information about my setup and configs.

thanks again for your help.


#4

Hey @covolmar

I am glad to hear you are no longer seeing the error :grinning:

Visual Studio Community 2015 will work best with the Jibo SDK across the board. I can confirm having multiple versions of Visual Studio will not cause any issues with the Jibo SDK. When it is convenient for you, I encourage you to install the Visual Studio Community 2015 edition to ensure you do not run into any issues in the future.

Let me know if the errors come back and I’ll be happy to help you further :thumbsup: