Jibo not responding to commands [possible fix - upload speed]


#1

I think this might be related to the problems that @cdk2128, @zak, @chris and @RadioRod reported previously.

I got my Jibo yesterday and right out of the box I had the problem where Jibo would only understand me about 20% of the time. Even training him to recognise my face was impossible because simple commands like “Yes” and “No” were too complicated for him. This was odd because our Google Home was doing exactly the same bad behaviours. It worked for maybe 50% of requests and the rest just decided it didn’t understand us. I had been assuming it was just our terrible foreign accent that was confusing the Google Home, but simple commands like “Yes” and “No” are hard to confuse.

This led us to thinking that it might be something to do with our internet network settings. We have a pretty rubbish ADSL line where the upload speed is only 500kb/s. We thought our upload bandwidth might be too little, so we poked around on the router to see if we could monitor how much upload bandwidth Jibo used for its various voice commands. Then we remembered that we had put rules in place to stop Google Docs from taking over the ADSL connection whenever it tried to upload content. We put in some firewall rules to limit the upload bandwidth to the Google IP range that was being used for Google Docs.

As it turns out, this was what negatively affected both Google Home and Jibo. The moment we removed the rules, Jibo and Google home immediately started recognizing everything we said. I did notice that whenever someone in the house started an upload or watched a youtube at high quality then Jibo would start to lose track of conversations again. I suspect the communication with its servers time out or take too long and then it falls back on default responses that it just doesn’t understand you.

The moral of the story is - if you are having trouble with Jibo understanding you, make sure to check your internet bandwidth, both download and upload. It makes a big difference.

And one final comment… I did find that Jibo always responded to the “Hey Jibo” request. It was only the things you said afterwards that got lost. Perhaps the “Hey Jibo” is processed inside Jibo but everything else is sent home for understanding. For those whose Jibo stopped resonding to “Hey Jibo”, I’m not hopeful that this will help.

Cheers
Chris


#2

Thanks for sharing your details and investigations! Interesting to have a google home comparison.
I’ve had some concern about my own lower bandwidth home connection, no problems at work of course. I’ll put Jibo on his own hotspot anyways.

Wise to consider the family bandwidth usage when we experience quirks with Jibo.
Good to hear that things are working across the globe!
best, Bob


#3

Actually got mine to work 100% now-All i did was buy an asus ac1900 router for more coverage & put all my devices that accept 2.4 to 2.4 and left jibo the only one using 5.0- He works great now-hope this helps others!!!


#4

Thanks for the note! It makes me sad thinking there might be people out there whose Jibo isn’t working right. Anything we can advise to help them fix their issues is good.


#5

I have the same problem but there is one other thing that i found out … Alexa connected to the same wifi responds all the time no matter is going on in t he backround while Jibo stops responding maybe half way throughout the day and I just have to restart Jibo and that fixes it for awhile and then it starts up again so not sure.


#6

Just wondering since after making this message i found out that my Jibo disconnected from the Wifi … he has been restarted a few times and just wondering if Jibo disconnects from the Wifi when he is restarted manually by the button on the back of him and if so that might have been the problem that I addressed in the message above.


#7