Jibo sdk installation error on windows7 64bit


####1. Describe Your Issue

I got installation error of jibo-sdk on my windows7 64bit PC
I already know jibo sdk’s minimum windows version is 8 but I think win version is not the main cause of this error
You can see the error log of atom at the end of this post

####2. Your Current Setup with SDK

Providing details about your system/SDK setup can save time by pre-answering common questions the community may ask.

  • Operating System: Windows7 64bit
  • Amount of RAM: 8GB
  • Node Version:
  • Atom version:
  • Does it say {$project} in your Run Directory area? (to right of simulator play button)

result of apm -v
apm 1.16.1
npm 3.10.5
node 6.9.5 ia32
git 2.12.2.windows.2
visual studio 2013

If you are using Windows

  • Command line tool (Git Shell or Git Bash): installed (Do you need version info? how to check?)
  • Visual Studio Version: Visual Studio 2013

Error log

Installing “jibo-sdk@1.7.1” failed.Hide output…

electron-prebuilt-reentrant@0.34.1-0 postinstall C:\Users\SIHYUN~1.LEE\AppData\Local\Temp\apm-install-dir-117313-5936-qmf3hw.vinrd4pldi\node_modules\jibo-sdk\node_modules\electron-prebuilt-reentrant
node install.js

Downloading electron-v0.34.1-win32-ia32.zip
[> ] 0.0% (0 B/s)
e[1000De[0Ke[1Ae[1000De[0Ke[1Ae[1000De[0KDownloading electron-v0.34.1-win32-ia32.zip <= My PC is 64bit not ia32 why ia32?
Error: unable to verify the first certificate <= what is the first certificate ?
`-- (empty)

npm WARN deprecated node-uuid@1.4.8: Use uuid module instead
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated husl@5.0.3: Project renamed to HSLuv
npm WARN deprecated wrench@1.5.9: wrench.js is deprecated! You should check out fs-extra (https://github.com/jprichardson/node-fs-extra) for any operations you were using wrench for. Thanks for all the usage over the years.

throw err
Error: unable to verify the first certificate
npm WARN enoent ENOENT: no such file or directory, open 'C:\Users\SIHYUN~1.LEE\AppData\Local\Temp\apm-install-dir-117313-5936-qmf3hw.vinrd4pldi\package.json’
npm WARN apm-install-dir-117313-5936-qmf3hw.vinrd4pldi No description
npm WARN apm-install-dir-117313-5936-qmf3hw.vinrd4pldi No repository field.
npm WARN apm-install-dir-117313-5936-qmf3hw.vinrd4pldi No README data
npm WARN apm-install-dir-117313-5936-qmf3hw.vinrd4pldi No license field.
npm ERR! Windows_NT 6.1.7601
npm ERR! argv “C:\Users\sihyung36.lee\AppData\Local\atom\app-1.16.0\resources\app\apm\bin\node.exe” “C:\Users\sihyung36.lee\AppData\Local\atom\app-1.16.0\resources\app\apm\node_modules\npm\bin\npm-cli.js” “–globalconfig” “C:\Users\sihyung36.lee\.atom\.apm\.apmrc” “–userconfig” “C:\Users\sihyung36.lee\.atom\.apmrc” “install” “C:\Users\SIHYUN~1.LEE\AppData\Local\Temp\d-117313-5936-1t5lujq.9jcka6pqfr\package.tgz” “–runtime=electron” “–target=1.3.13” “–arch=ia32” “–global-style” "–msvs_version=2013"
npm ERR! node v6.9.5
npm ERR! npm v3.10.5

npm ERR! electron-prebuilt-reentrant@0.34.1-0 postinstall: node install.js
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the electron-prebuilt-reentrant@0.34.1-0 postinstall script ‘node install.js’.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the electron-prebuilt-reentrant package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node install.js
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs electron-prebuilt-reentrant
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR! npm owner ls electron-prebuilt-reentrant
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! C:\Users\SIHYUN~1.LEE\AppData\Local\Temp\apm-install-dir-117313-5936-qmf3hw.vinrd4pldi\npm-debug.log
npm ERR! code 1


Hi @Sihyung

It looks like there are a couple of our other dependencies/installation requirements that are not in place with the correct versions. I recommend making sure that the jibo-sdk did not install at all (you can do this by going to your home directory, cd $home , entering cd .atom/packages and then enteringls to view the contents of the directory.) If you do see an entry forjibo-sdk in that directory I recommend entering rm -rf jibo-sdk to remove it so that you are working from a clean slate.

Once that is complete you will want to adjust the following dependencies:

  1. It looks like you are currently running node 6.9.5. As noted in our install docs you will need to have node version 4.5.0. A direct install links for that can be found here.

  2. It also looks like you are running Visual Studio 2013. The SDK on Windows requires that you have Visual Studio Community 2015.

  3. You will also want to make sure you are running atom version 1.11.1. You can check that by entering atom -v into your command line tool.

Once those versions are in place I recommend following the install steps again. Let me know if you continue to have any trouble installing after taking those steps.