NLU Parser module failed to load


#1

Today appeared this error message in the Test dialogue rule in my SDK:

From the error message, I don’t understand if it’s supposed to be so and I just have to wait for the jibo-sdk update or I need to fix something.

I’ve already tried to reinstall all node modules.

Thank you.


#2

I saw the same error when I was working in the NLU Parser both yesterday and today. Looks like they’re making an update which caused some issues in the current release.


#3

Hi everyone,

Thank you for letting us know you’re seeing this and my apologies for any inconvenience it is causing.

I’m going to touch base with our team and if there is any workaround that can be used prior to an update I’ll let you know.

Most of the team is not in the office over this weekend so it may take until Monday morning for me to post further info.

Thank you for your patience!


#4

Hi everyone,

Thank you again for your patience over the weekend. It turns out that this error occurred due to the latest update in Atom.

The best fix at the moment will be to roll back your Atom to an earlier version. I’m going to provide steps on how to roll back to an earlier version but I also want to make sure you know that you can avoid automatically updating to new versions of Atom by going to Atom -> preferences -> core in atom and unchecking the "Automatically Update" box on that page:

To roll back to the last stable version of Atom you can go to Atom’s releases page on github for the last compatible release here. You can download the appropriate zip for your operating system (atom-mac.zip or atom-windows.zip) to get that version of Atom.

On Mac this will create a second application (by default it is usually called Atom 2 ). If you open this it should allow you to use the SDK as normal but without this NLU issue caused by the recent Atom update.

On Windows the steps are the same but you may also need to re-download AtomSetup.exe from that release page to initially launch the program or you can use file explorer to locate Users//AppData/Local/atom/app-1.11.1 and click “app” to launch the rolled back version of Atom.

Keep in mind, if you are used to opening your Jibo skill from the command line you may need to open it using File -> Open in Atom so that it does not open by default in the 1.11.1 version that is seeing this issue.


#5

Thanks, that cleared it up for me. I thought I had automatic updates turned off already, but looks like not…I turned it off, installed 1.11.1, and the issue is now fixed.