Pixi Errors in Jibo SDK

As mentioned in this post progress towards new features in the forthcoming SDK have caused a change in the current (1.7.1) SDK that results in the following error when the SDK is freshly installed or when using the simulator for a skill:

Error: Cannot find module 'pixi.js/bin/pixi.min.js'

Fixes for aspects of this can be seen in this and this thread.

Additionally, a more global fix can also be achieved by cd’ing into C:/Users/<username> on Windows or users/<username> on OSX and running the following terminal command:

npm install pixi.js

This should allow you to create new projects in the SDK without having to separately install pixi.js for each skill.

This issue will be fixed without needing to run to run a command in a future SDK update.